Hi there and welcome to the Chaser manual!

Chaser is an application and a set of plugins that help you get more out of your slices in Resolume. This document exists to make it easy for you to get up and running. It explains the best way to use the plugins and how to get the most out of the app. After a short intro on the importance of input maps, it will go over the features of the app and then cover each plugin in turn.

I know you have better things to do than read page after page of technical mumbo jumbo, so here’s an index to help you quickly find the topic you want to know more about. Also, I added pictures in between all them word thingies.

Table of Contents

Using Input Maps

Before we get started with Chaser, first a word on Input Maps.

Input Maps are the key to a good show with Chaser. In fact, Input Maps are the key to a good show in general! If you’re doing any type of setup that is more than a single 16:9 output and you still want to be flexible with it while playing live, you’ll benefit from using Input Maps. 

So what’s an Input Map? An Input Map is a logical layout of all the slices and screens that make up your stage. It’s used to lay out content and to decide which screens show what. When creating custom content, it will serve as the guide to render everything to. During the show, it is the preview that you use to check if everything is going according to plan. Essentially, the Input Map is the representation of your stage in Resolume and other software.

How to make an Input Map? First you’ll need to know the position and size each LED panel will have in the LED processor. This is essential and you won’t be able to do a good show without it. Your LED supplier should provide it to you. Each tile becomes a slice in Resolume’s Output Transformation tab, each processor becomes a screen. You then take all those slices and on the Input Selection side, you right click and choose Match Output Shape. This way the sizes match exactly. You then lay them so that each has its own little space in your composition, roughly in the same place as it has on the real stage.

To be 100% clear, we’re talking about the Input Selection side of Resolume’s Advanced Output here. In order for Chaser to do its thing, every slice needs to have its own place in the Input Selection. If you’re using slice routing to create your looks, or otherwise have overlapping slices, you will not have a good time.

The images below show how to go from stage to output map to input map.

Creating an Input Map is a skill like any other. You learn by doing and you get better at it the more you do it. Still, if you’re just starting out, here are some tips for creating a good Input Map:

  • When naming slices, follow the naming convention the LED provider is using, even when it doesn’t make the most sense. Communicating with the technical crew on site is a lot easier when you both call the same thing by the same name. 
  • In general, smaller is better. The resolution of your Input Map is the resolution Resolume will be rendering at, so the smaller it is, the more processing power you have available. But….
    • Having a clearer, easier to read pixel map outweighs optimized performance. Remember that your Input Map is your view of the show, so 1 or 2 extra fps are useless when your map is a puzzle where you can’t find anything.
    • When your stage is symmetrical, make your Input Map symmetrical too. This makes it easier to create mirrored looks.
    • Keep an 8 pixel gap around every slice. This way you have some margin for error for any misaligned panels or bleed from any AD conversions in the signal chain.
  • If you like them perdy colordy thingies, you can make those with the Chaser app. Just choose File > Export Pixelmap and it will save a PNG for you automatically. 

Using Chaser

Once you have a good Input Map to work from, it’s time to open Chaser.

Nothing is more scary than a blank canvas, so when it first launches, Chaser will automatically open the Advanced Output preset you just created in Resolume. If you have more than one Resolume version installed, it will ask you which one to use.

You will then see all the slices exactly as they are laid out in Resolume. The big difference is that they are now buttons that you can turn on and off.

InChaser

On the bottom you will also see 16 additional buttons. These are the steps of your first chase. Making a chase is super easy. You select step 1 and click all the slices you want to see in step 1. Then you select step 2 and click all the slices you want to see in step 2. Rinse and repeat until you have the perfect chase. Then hit Play to see your beautiful chase in action. See, told you this was easy!

Don’t worry about speed and direction right now. You control those live, directly in Resolume, using the plugins. We’ll get to that in a bit!

The sequencer

Chaser has room for 16 sequences. Each sequence can have between 1 and 1024 steps. Each sequence can be renamed to make it easier to remember which one is which. You switch between sequences by hitting the forward and backward button. You can also quickly jump to a sequence by directly entering a value in the number box in front of the name. 

Sequence

You add and remove steps with the + and – buttons, or directly setting a specific amount in the number box. You jump to a step by clicking on it, or you can hit the left and right arrow keys to go to the previous and next steps.

By dragging one step to another, you can copy and paste steps. If you’re so inclined, you can also use the old fashioned CTRL/CMD – c and CTRL/CMD – v for this.

By dragging one step to another and holding it, you can multicopy a step to every other xth step. So for instance, step 1 will copy to step 5, step 9 and step 13. This is useful for making odd/evens or repeating patterns.

Tip! It’s best to make sequences with the same amount of steps as much possible, to prevent big changes in visual tempo when switching sequences in Resolume.

The list view

On the right side, you see all the screens and slices in a list view. In the list view, you can fold and unfold screens. This doesn’t do anything to that screen in Resolume’s Advanced Output. Folding a screen just hides the slices in that screen in the Preview in Chaser. This is helpful if you need to focus on a specific part of your stage, or if for whatever reason, you do have overlapping slices and want to work with the set underneath. If you like, you can also fold the whole stage list itself for those hyperfocused chase creation sessions.

Ghosts

You can also toggle the visibility of an individual slice. Again, this doesn’t do anything to the slice in Resolume’s Advanced Output. It just hides in the Chaser Preview. It will draw itself with a stippled outline to remind you that it’s actually still there. 

The canvas

In the top left, you will find the navigation controls. The zoom percentage speaks for itself, but it’s good to know that you can also zoom by hitting CTRL/CMD + and CTRL/CMD -, scrolling with the middle mouse, or two finger swiping on a touch pad. You can enter a specific amount or hit the crosshairs to fit the canvas on screen.

Selecting the hand tool will let you pan the canvas. If you’re so inclined, you can also hold down the spacebar to pan.

While we’re here, you can multiselect slices with the mouse to flip the state of the slices in the bounding box. During multiselect, you can also use modifiers. By holding down SHIFT, all slices in the bounding box will toggle on, by holding down CTRL/CMD they’ll toggle off, and by holding down ALT, all slices in the bounding box will toggle their ghost state.

You can also snake across a series of slices to flip states quickly.

The File and Edit menus

Any changes you make are always saved all the time, automatically. Any changes you make are also automatically picked up in the plugins. So there’s no need to save manually. If for some reason it couldn’t save the latest changes, Chaser will let you know. 

So what can you do in the File menu? Well, for starters, you can start a new Chaser document. By hitting File > New, Chaser will find the current Advanced Output setup file and load it in. If there are multiple versions of Resolume installed, it will ask you which one you want to use.

Tip! As long as Chaser is open, any changes you make to Resolume’s Advanced Output are picked up the moment you hit Save & Close there. Chaser will adopt the changes automatically, including all instances of the plugins that are currently active.

By hitting Save As…, you can save the current Chaser document with a specific name. This shouldn’t really be necessary when working on a single show, but it’s helpful if you’re preparing multiple shows in advance or want to share your chases with somebody else. In turn, you can hit Load to load a previously saved Chaser document.

By hitting Export Pixelmap, you can export the currently loaded setup as a PNG file with those lovely colored tiles you like so much.

The Edit menu has options to Copy/Paste Step the old school way, and to quickly Clear or Invert the current step.

Using the plugins

Finally! We get to the good bit: playing your chases in Resolume! Chaser comes with a suite of six plugins and this section will handle each plugin in detail.

Chaser

Chaser is the original classic that started it all. It’s a basic player for the chases you’ve created in its namesake app. All you have to do is set the Step parameter to Timeline or BPM Sync, and drag the Sequence parameter to the sequence you want to play.

Of course, each instance of the effect can be tweaked further to perfection.

By changing the Scaling, you change how Chaser scales your content into each slice.

  • Fill is the default and it shrinks your content to fill the whole slice, while maintaining the aspect ratio. It crops off any parts that fall outside the slice.
  • Mask doesn’t scale your content at all. When chasing, Chaser will cut just holes in your content where each slice is. This mode is best used if you have custom content that already matches the Input Map and you want to use Chaser to add more dynamics to it.
  • Stretch stretches your content to fill the slice, disregarding any aspect ratio. In 99% of the cases, this mode is horrible and you should never use it, but maybe you can find some creative use for it.
 

Sequence controls which sequence this instance will play. Moving the slider will cycle through the sequences you created in the app. It will display the name you gave it in the app for quick reference.

You use Step to control which slices are visible. You’ll probably want to animate this to BPM Sync, Timeline or even FFT. But you could also set it on a fixed step to use it as a quick masking effect.

Echoes are a quick way to keep a step visible for longer. For instance, by setting Echoes to 4, each step will remain visible for 4 steps instead of 1, before it fades out. You could get the same result by toggling every slice manually on more steps in the app, but come on, ain’t nobody got time for that.

Sustain and Release determine the curve of the opacity fade during each step. By default, they’re set to 0.2 and 0.8, which means each slice will be 100% visible for 20% of the step’s duration. It will then fade out to 0% over the next 60% of the step’s duration and remain completely invisible for the last 20%. By setting them to 0.0 and 1.0, it would fade out from 100% to 0% over the full duration of the step. By setting both to 1.0, there won’t be fading at all and it just hard cuts at the end of the step.

Bumper

Bumper followed quickly on the heels of Chaser and is great for a more hands on percussive approach to VJ’ing.

It has the same options for Scaling as Chaser, so see above. Similarly, you also select a Sequence much the same way.

Instead of an animatable Step slider, Bumper has Next and Previous buttons. You use these to manually tap from one step to the next. This is great for tapping out melodies or hitting musical accents.

Tip! Bumper is meant to be played musically. If it doesn’t receive any input, it will assume the melody is over and reset to the first step. This way, the sequence will play from the beginning next time you play it.

There’s also a Blast button, which will cycle through the steps quickly in succession. This is great for building climaxes or going wild on the drop.

You control how fast the slices fade out with the Speed parameter. The higher this value, the quicker they will fade out. The fade out curve is defined by the Sustain and Release parameters, described above.

Random

I love random number generation and so of course there is a Random plugin in the Chaser suite. Random does what it says on the tin, it makes a random selection of slices and chases those. You can tweak the selection using the following parameters:

Selection is helpful when you want to narrow down the set of slices it picks from. By default, it’s set to All, which means it will randomly select from all the slices in the currently active Advanced Output preset. By switching to Step, a Sequence and Step parameter appear. This allows you to set a specific sequence and step to select from instead.
 
Max Slices controls how many slices the random selection will consist of. Everything is still random, so setting this to 4 will give you between 1 and 4 randomly selected slices on each step. This value is limited to a maximum of 7, or half of the available slices, which ever happens to be lower. It’s dangerous to tell a computer to select more slices than there are. It would start creating slices itself and soon it will devour humanity in its hunger for more slices.
 

Similar to Bumper, Speed is used to control how fast the slices fade out and the next random selection is made. 

ScalingEchoesSustain and Release all also work exactly the same as above.

Outliner

Outliner is a little different. Its main function is to create outlines around your slices. So it’s a Source and not an Effect, and it can be found in Resolume’s Sources tab. Also, Outliner is available on Resolume 7 only.

It’s a very straightforward effect so it has only a few parameters.

First off, it has the same Selection parameter that Random has. You use it to either create outlines on All your slices, or narrow it down to a specific Sequence and Step. 

Tip! Don’t use the Step parameter to animate the outlines, because you won’t get smooth fades. Instead, set the Step to a fixed value containing all the slices you want to see outlines on, or just keep it on All. Then apply a Chaser effect in Mask mode on the clip to actually animate your slices.

Width sets the size of the stroke in pixels. This is pixel accurate and always stroked on the inside of the slice, even on complex polygon shapes. So you will never get bleed on neighbouring slices, even if they are right next to each other.

Tip! You’re not a baby, so I don’t need to hold your hand and give you a color parameter. You’re old enough to know how to apply the Colorize effect if you’d like to have color in a clip.

Tiler

Tiler is great for creating animated pixel patterns inside your slices. It’s available on Resolume 7 only.

It’s designed to really be a Bob Ross type of creative tool. You fiddle around, causing happy accidents until you see something you like. It has a crazy amount of parameters to play with and with most of them being visual, it’s best to just see it in action in the video below.

Sampler

Sampler is the latest addition to the suite and she’s all about using video to drive your chases. It samples the pixels underneath your slices and uses that data to change how each slice looks. Sampler is available on Resolume 7 only.

Similarly to Random and Outliner, there is a Selection parameter that lets you narrow down which slices get used for this instance of the effect.

Sample Mode controls how the pixels underneath the slice are sampled:

  • Center just samples one pixel at the center of the slice. This gives nice high contrast results and is also fastest performance wise.
  • Average samples at the center and at the four corners and then averages that. This is slightly slower to process but gives a more even result.
  • Blend samples at the four corners and then blends between them. This gives a very smooth result and is great to create happy, colorful atmospheres.
 

Color Mode then determines how the sampled pixel data should be displayed:

  • Color just uses the resulting color as is. It will display the slice in the sampled color.
  • Luminance uses the brightness of the color instead. It will display the slice in a shade of white.